Nvidia Shield Issues

Hey guys, hoping someone can help me with these problems before I chuck these F&$%ers in the garbage.
First off, I have had 2 shields for about 3ish years. They have been pretty solid up until this latest cluster 9.0 upgrade. They both still function but some issues I cannot resolve.

#1 Box
I decided to try the 9.0.1 on this box, well it tells me download is installed, restart to install download. It will not restart when clicking install button, just goes back to home screen with settings menu open. Tried rebooting, unplugging ( over night ) numerous times still won’t upgrade to the 9.0.1.

#2 Box
This box had the 9.0 upgrade but not the 9.0.1 until I tried to download off Syncler to my external hard drive & get a Storage Permission is Required to Download. So I seen the 9.0.1 supposedly resolved storage permission issues. Well it didn’t.

So now I have 2 boxes that won’t download to external storage, & 1 of them won’t upgrade.
Does anyone know if this is a Syncler issue or a Shield issue( download problem). I’m ready to do a factory reset on the non upgrading box but only as a last resort. Any constructive advice welcomed.

Well, since you did the update. Why not go the extra step and sign up for the hotfix program. Nvidia just dropped a new hotfix a few days ago.

Ya no. I’ll cut my losses here, boxes still work. Found a work around for the downloading. Nvidia frick’n destroyed these boxes.

1 Like

Call Nvidia…I am sure someone in the company can help you… Don’t chuck them in the garbage. Give them away to someone who can use them. Customer service has alway been good to me…I love mt Shield!


This topic was automatically closed after 7 days. New replies are no longer allowed.