Newly installed Cinema not showing results

Just yesterday, 10-30-21, I installed latest Kodi and Cinema. Kodi works fine, but Cinema does not. i added my Real-Debrid account info into Cinema, it finds an old show, it’s seasons and all, but when i click for an episode, it just spins, nothing else happens. I followed the Troypoint instructions and all so baffled. I know there are other posts for Cinema but have tried all their suggestions.



Thank you and welcome to our site!

Glad you are using the search feature but as many stated cinemahd has issues with links even with real debrid.

The best setup for cinemahd is real debrid and mx player or vlc.

If still encounter issues I’d use kodi and the crew Streamio or syncler plus with real debrid.


thanks for getting back to me. i just uninstalled it and will try Syncler. i’ll let you know how i make out. if that doesn’t work, i will go the Kodi route. :slight_smile:


When it comes to syncler be sure to read the guides, it can get a Lil frustrating for beginners.

When you get to the packages you will only be allowed kosmos I have a great setup for that.

I fully recommend s+

Anyways let us know.


Great options as well.

Hi @CaptPhil
Another good option is Seren add-on with real-debrid in addition to the good suggestion offered by @TP-Dracoo.

1 Like

i seem to be hitting a brick wall. I updated my stick, which is the older version as I only have the one option to allow all under the developer section. added the Kosmos per the instructions, added my Real-Debrid and TrakT accounts. Both were accepted fine. searched Medical Center (for my wife lol) see all seasons, no pics for the episodes, but when i clicked the an episode, it “couldn’t resolve” any of them.

any thoughts?

After making many changes like you show restart the stick and see if that works please.

I’ve done all that, may be what i’m trying to watch as my friend tried on his and gets the same. my wife is trying to watch the old “medical Center” series and I cant find it on a server. I used to get it on Cinema but now it does play. it finds the episodes adn all, but no content


Remember not to mention names of shows and movies.

But for your current issue with syncler there is only 2 good kosmos links but use the bouncy one has it has the most.

You can pm me what your trying I will look for it. I will tell you the plus is way more active for links.

Older shows tend to lack a bit, I find that stremio has alot of older stuff and kodi with seren and crew.

1 Like

sorry about that slip… i will try the kodi with seren and crew

1 Like


Awesome, I fully recommend syncler plus and real debrid.

It will have everything. But check out kodi with seren and the crew. Enjoy!

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.