MX Player forces me to manually select audio stream

I’m newish to IPTV so forgive me if this is a simple fix but, I’m using MX Player from the appstore on Cinema HD (FireTV Cube 2nd Gen / Firestick 4K Max). Oddly enough, when I start playback, there is no audio. I’ve read up on the codec issue but all I need to do is go to the “note” icon and select the track. For some reason, it’s defaulting to disabled. I assume that since I can enable it, I have the codec but it forces me to do this every single time. What could be the issue?


Hey spirit…

The codec is the hw,hw+,sd setting u c in top right (next to note), switch that & youll probly get sound…

The note is alternate tracks of audio…


1 Like

Yep like Sketch said pick hw+



You can go into mx settings decoder and turn off sw.

Please see this mega cinemahd troubleshooting guide.

1 Like

Thank you. That’s actually what it’s set on so must not be the issue

1 Like

Unfortunately that’s what it’s set on so must not be the issue

This topic was automatically closed after 7 days. New replies are no longer allowed.