MECOOL KM6 soundbar problems

Ok,…had this for about a week, some set up issues that im having,… this is running android 10 same as onn box but they are different. The km6 will operate my soundbar, but only if the volume is turned up on the soundbar , it increases the system volume but not control the soundbar, where as the firesticks, onn boxes, x5 , all controlled the soundbar.

Second problem is using launcher manager & wolf,… I can get it set up, but when i reboot it goes to black screen and no remote buttons work except YouTube,…YouTube will launch, then google voice will work and I’ll ask for settings,…click on wolf and we’re back working.

Hard to believe there is that much difference between onn andoid 10 and mecool android 10,…but there is.

for sound issues, dig into settings and look for cec settings. Wolf launcher works great on my km6 so not sure. Might uninstall wolf and launcher manager and start over. Remember to start wolf 1st, before you start launcher manager, then after starting wolf, start launcher manager and set it up from there.

Yea,…cec settings are on. E-mailed them for a software update, they sent a update, didn’t help.

Wolf and Launcher Manager work perfectly on my KM6s. Maybe reinstalling these in the order @TXRon mentioned above will help. Never had an issue with either of these on it. If you are still having multiple issues that aren’t fixing, may be worth factory resetting the box.

@TXRon did a few factory resets,…1st time YouTube, google play and amazon prime were disabled, so no buttons worked, had to do a reset using switch on box. I always set up wolf first then launcher manager. Probably setup 10-15 boxes of various types,…never had one act like this.

understood, ive never had an issue with a mecool box before, could be a dud?

Maybe it is bad out of the box? I love my KM6s and they have done anything I have ever asked of them.

I love the box, just not the software. @TXRon you have any software updates from mecool to try?

That’s a compressed zip file. Did you unzip it? I think you can unzip it with say xplore or esfileexplorer. Then you’ll have the install file like an APK.

believe it or not, Ive never updated a mecool box.

1 Like

Used the software update in mecool, it unziped and installed

1 Like

Ok,…ill email them again and see what happens.

Ahhh. Ok. Excellent. I’ve done and updated a KM2 but never had problems. The compressed zip was all I saw that might cause you issues but you’re g2g. Curious what solution you find. good luck.

Going fresh,…installed wolf and ran it ,…installed launcher manager,… instead of wolf showing up i get this… second screen is from my onn box.


@TXRon @AMD237 @Miki Hey guys,…when you boot up the km6, does your start up screen say android or android tv?

Yea,…thats what I have also,…thanks.


1 Like

Hey @ljstew51957 Just an FYI on the ONN box OS…I believe its had 2 updates/patches on its Android 10 OS…first was for remote pairing issues (its remote is used by KM2 & other android boxes, but the KM6 has a different, more basic remote, which I like better) & the second update/patch was for some other minor things. KM6 last update was 2 yrs ago…I’ve had my KM6 for just over a year & have had no problems (that I haven’t caused myself)…so, I’m good with no updates. I don’t use Wolf Launcher, so I can’t help with any of your current problems…just thought I’d drop what history I know of both boxes, which I also use. :cowboy_hat_face:

2 Likes

It is puzzling to say the least. Ive actually had no issues with the mecool boxes except for issues that I created myself :crazy_face:… and generally when I do have issues with setup I go back to the basics with setup and build it back up. I often get complacent with boxes because ive set up so many that I rush the install and setup and in the process miss something important…

2 Likes

Ok,…I have the wolf /manager worked out,… I forced stop both apps, clear data, uninstalled. Installed wolf from tduk and launch manager from rai. Installed wolf, then manager, enable custom launcher and wolf showed up,…did a reboot and perfect. No idea what the problem was,…tried this same method probably 5 times with same problem,…only difference was wolf was downloaded from tduk this time. :sweat_smile: :thinking:

3 Likes