Kodi with Real Debrid

Anyone having trouble with the Seren add-on? I had no trouble last week, and this week I’ve had trouble streaming Movies/TV shows with Real Debrid links. It tries to load the selection, and just prior playing, it drops out and throws me back into search. I should also mention this is on my Galaxy S10 (android).

Yes. Same thing is happening to me. On Firestick 4

It’s strange because prior it was seamless. I saw where the devs went in and changed several Debrid settings, and am wondering if that pertains. I’m seeing a message about Seren attempting to build Torrent cache upon link selection so…?

Yes, also same problem, have tried everything I usually use syncler or cinema apk, but if I have to use kodi I use exodus redux or the crew, hope someone can be more helpful, sorry. Jimmy

Thanks Jimmy. Yeah, but the funny thing is…I have zero problems with the Seren add-on loading/playing when on the Amazon Firestick 4K. Also had problems with the latest Kodi release (18.9), so I loaded (18.0)…seamless at first, but dropouts after~all on my Galaxy S10.

I’m also having real debrid issues with exodus redux and the crew. Redux will start a movie then terminate it within seconds. The crew just spins forever, never grabs a working link. This started a couple of weeks ago, everything worked beforehand.

I will try Seren again a bit later on and let you know what happens as I haven’t tried in a while, it started to compile a list of streams lots of 4k, 1080 Real Debrid, thought OK I’m in here, then as usual kicked me out. Out of curiosity what kodi build are you using. Thanks. Jimmy

I’m using Leia 18.8.

What is the deal with the torrents in Real Debrid? There are times when there is nothing but a torrent and they all want to download. Where are the links for non-torrents? The torrents don’t download anyway. Is there a way to watch torrents without the download. I’m frustrated when I go into kodi and there are no RD links that aren’t torrents or they don’t work.