Just downloaded, won't open

I just downloaded Kodi to my :fire: stick and when I try to open it, it just goes to a blank page, nothing ever loads. I also have Cinema on there and it is doing the same thing. What am I doing wrong?

Neither are doing anything when you open them? Sounds like a firestick issue. Have you tried restarting it? Or doing a hard restart by unplugging for a minute and plugging back in?

Yes, I have tried both of these things. Could it be anything to do with not running a VPN? Like Firestick blocking it or something? I’m not very knowledgeable about this type of thing.
I have had Cinema on there for a while, but it often has incorrect links and no live TV so thought I would try Kodi then as soon as I got through downloading Kodi and the Diggz add-on pack per the Supercharge Video #2 instructions it all just stopped working.

How is your storage space looking? Go into your settings and check how much is left. I’m about to post a video in a bit on how I use Kodi. Some of those builds are just too big and more than anyone really needs.

1 Like

That could be it, I’m not with that TV right now, but I am pretty sure the storage space is getting low. My main goal for it is to watch Live TV. I don’t know what is best to use for that.

Tivimate if you have a subscription to an IPTV service. There’s nothing even close to it.

Is this one that Troypoint has directions for how to download? I don’t have nay subscriptions for any IPTV services.

Yes V…
Troypoint has everything but u need to decide if you want to go “free tv” or your willing to pay $5-15 a mnth for a lot less hassle & a lot less learning & button pushing… with tivimate & a service u get a more cable-like experience with easy to use tv guides & channel selection… -a lot of channl selection

1 Like

Greetings, What version of Kodi are you trying to load and what device are you loading it on?

1 Like

@VBoyMom

Try Uninstalling unneeded apps and storage. Clear app data along with caches.

Reinstall kodi and or cinema and try again.

Posting firestick link incase it’s needed.

Setup guide.

It sounds like a storage issue or all it’s ram is being allocated. Disable background apps.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.