Issues using VPN

Good morning all. I’m a newbie and not very tech savvy so please bear with me. I had been foolishly using crew and real debrid without a VPN for months. About a week ago none of the rd links play and returns with a message stating “no stream avail”. I decided to sign up for a VPN (surfshark) and now all my devices are incredibly slow. I have 1 gig fiber and when my VPN is turned on it runs slower than dial up service. I cannot even do a speed test as it just sits there and does nothing. Laptop, desktop and firestick just runs at a pace as if it’s slower than dial up. Again, I’m not tech savvy at all so please be understanding. Please help!

Hey @Greyson Open up SS & set up Fastest location…Nearest country (depending on where you are…if in US probably not needed) & set your Protocols to Automatic…see what that does & let us know :cowboy_hat_face:


May have some insite on protocols here.

1 Like

Same results. I tried a speedtest and it stated " Test cannot be completed due to problem with the network". I’ve tried several different locations within the US and outside all with the same results. I have to log out of the VPN just to come to this page and post. Some websites will load up at incredibly slow speeds while others won’t even load. Would canceling surfshark and going with another be a better fix?

Are you using the app or router?

OK…sounds like there may have been some kind of software conflict when it was downloaded & set up. Might be time to start all over…uninstall the SS app & download it from Playstore or Amazon…not sure what kind of device you have…sign in…check what I previously mentioned & do a speed test with it off then with it on…& we’ll go from there. Also, after you’ve downloaded it…reboot your router & device before you take tests.

From his “not very tech savvy” line…I’m assuming he’s just using the app… :thinking:

you may be right. :face_with_monocle:. The app could have defaulted to “kill switch” and might need configured correctly.

I’m using the app they provided for my Firefox browser on my Mac, iPhone app and also the firestick. All of the devices are extremely slow once I connect to the VPN. In fact the links from real debrid won’t even come up for me to try and play.

I want to thank you for everyone’s help so far but wanted to inform you that I must leave for a lunch meeting and will be back in two hours.


Copy that @Greyson I will be deferring to those that are Mac & iPhone savvy…as I’ve always been Windows & Android…GL2U :cowboy_hat_face:

1 Like

Well, a little update on the situation. Out of curiosity I tried the firestick/kodi in my living room with surfshark. Long story short, everything works fine and links are loading up to play with no issues. I also added surfshark to the desktop computer and again works like a champ. The mac laptop is the one having issues under firefox and I will now try it with another browser. The firestick I was having issues with (in the bedroom) now will not even find the wifi signal. It’s like my ISP provided blocked IP address completely. Is this even possible? The provider is AT&T fiber. I’m running out now to purchase a new firestick and will let you guys know how it works out.

For what it is worth, my wifi is not super fast, but fast enough at 25m down. I use SS on my MacPro OS Monterey, v12.4 and I use Safari as my browser. I don’t lose any speed.

Had something similar with Surfshark and had to go into manage installed applications for Surfshark and force stop and clear cache…. Worked fine after that. Think it has something to do with the kill switch activated.