INCREASE STORAGE ON FIRESTICK 4K (not 4K max)

This post was flagged by the community and is temporarily hidden.

1 Like

I’ve literally spent hours trying to learn and get my external devices working/showing properly and still haven’t.

I’ve watched countless videos, tried multiple OTG cables, multiple brands and sizes of usb keys (3.0, 3.1), a portable SSD, used windows, linux, even scoured the web until I learned all the ADB Shell commands to do it via command line with no need for any other tools…

And I have yet to see even one attempt on any device used work as described.

I’m extremely puzzled. It’s not isolated to me others everywhere have the same issues, but I can find endless videos including the constantly updated TroyPoint walkthrough that show it working perfectly.

We’re missing something, a variable.

Right now I have a 120gb portable SSD connected. The storage functions fine so far (I’ll never use half that space, I bought it for speed). But in Settings the internal memory does not show the added capacity and in X-plore the external capacity is a rediculous number (570 something gb, sorry this is from memory).

As I said no problems as of yet and I may never have any but what the heck?

Capp

Hello @pacarlen this is usually due to a power problem. Not enough power to power the external drive and everything else you are throwing at it. Guys, I show that video because there are a lot of people that want to do it but if you are serious about having more storage of apps, I would suggest getting a device that has more internal storage. Yes, the process will work for most people but there are some things that will come up from time to time and power is one of them. So is trying to update apps that are residing on internal storage. I haven’t had any power problems with the SanDisk 3.0 USB drives. But, I personally only use approximately 6 applications on a regular basis, TiviMate, Syncler, YouTube, IPVanish, Kodi, and Plex. I don’t need anything else. So, I don’t need the extra storage for apps. The Fire TV Cube has 16GB of storage and so does the NVIDIA Shield TV Pro. BuzzTV XRS 4900 has 128! There’s a reason why the Firesticks are so cheap and the internal storage is one of those reasons, not enough. It’s too bad that Amazon wouldn’t add an additional 8 to their Firesticks as that would make a big difference.

5 Likes

Did you set the firestick to factory defaults first? Troypoint said to do that at the beginning of the video and said he would say why later in video but I did not hear him talk about it again. If I do not have to reset the FS to defaults I will try increasing storage again. It worked the first time I did it and all apps showed up with the transparent USB beside the apps but the next morning it was as if the firestick could not detect the USB drive so I had to reinstall all apps again on FS grrrrrrr. I agree with Troypoints comment below about getting a device with more storage but I like trying his videos for fun hehe. And if they do not work I want to know what I did wrong. BUT…is restoring FS to factory defaults first, the key to it working.

Hi Miki, I checked the link you sent. I have a firestick 4k. I cannot find it in settings. It is not under My Fire TV as in above tutorial link. When I plug the usb in it shows for a few seconds …bottom right of the tv screen that USB plugged in. It is already formatted using Rufus. Can you help? And also I cannot get anyone to answer if I have to reset firestick 4k to factory defaults. They give all other info but Troypoint said to do that at the beginning of his tutorial and said he would explain later why but I did not hear him talk about it again in video.

Correction to above msg. I cannot find USB in settings.

I’m yruly sorry but I have no experience attempting what you want. All I can do is point you to Troy’s vids for help and to search.

1 Like

This is why staying on topic is so important (I’m guilty as well).

Elsewhere in another thread Troy stated that you do not need to reset.

I’d add that if you’re experiencing problems already that resetting certainly wouldn’t hurt. Doing so eliminates possible issues later. It’s part of basic troubleshooting.

Fire Stick 4k won’t have a usb section in Settings.

I agree with Troy re power. It could also be a crappy powered OTB cable (loose connections or non working).

Capp

1 Like

Thank you for the reply, I accidently erased my post about the storage and my firestick powering off. I really do not have but a few things on my firestick at the moment. I do have TiviMate, Kodi, IPVanish, and Cinema and that is it. I added the storage because I was getting the message from the Firestick that I had too much on my Firestick and I was doing everything that I could to get down to nothing. I took Kodi off and I only had Cinema, IPVanish, and TiviMate and I was still getting the message even if I cleaned the cache on the apps. I saw your video on storage and it really did help me get past the every few minutes message from the Firestick. I am saving in my piggy bank for a NAVIDA Shield so maybe one day it will not be a worry anymore. Really, it is not that big of a deal when the firestick powers off, I just have to remember to make sure when it powers back on that the IPVanish is back on and I am good to go and I am still grateful for the video that you gave us on how to add storage. Trust me, having the Firestick power down is much better than the message from the Firestick telling me I did not have enough storage. Thank you again for all of the hints and help!

2 Likes

Just an update. I followed Troypoint video to increase storage on my 3rd gen Firestick and it worked. I will do this on my 4K today. My thinking is…if most Apps but not all) are on the USB then the actual firestick will run better. I also followed the debloat your firestick and so happy to see all those Amazon Apps gone. Hopefully if I disconnect the USB from the firestick and then plug it in again it still works as storage. The last time I increased storage it worked but when I disconnected the USB and plugged it back in again, it did not work and that was the same for both 3rd and 4K firesticks. That really boggled my mind why that happened.

I think my post was misunderstood. I did not say there was a usb section in settings. What I meant was that once you have successfully added storage when you go to settings/applications and look at the apps you should then see a “move to usb” option on some apps listed.

Moving Apps to USB Storage

  1. Ensure the USB drive is properly inserted and detected. You can even [install a USB drive on Firestick]. Check under “Settings” > “My Fire TV” > “USB Drive” to be sure the drive is detected properly.
  2. From “Settings“, go to “Applications“.
  3. Select “Manage Installed Applications“.
  4. Select the app you wish to move.
  5. Select the “Move to USB Storage” option. This option will switch to “Move to Internal Storage” if the app is already located on a USB storage drive.

1 Like
  1. Hi Miki, I solved my first problem. USB drive is listed under My Fire TV in settings for the 3rd gen Firestick. When I plugged my 4K it does not list the USB drive in My Fire TV. I thought there was something wrong but there isn’t. It is just not there on the 4K.
  2. As is said in my previous post I have successfully increased the storage on the 3rd gen stick.
  3. To get the apps on my USB I had to uninstall from firestick and when I re-install the app installs straight to the USB. I want to understand your Step 5. above because, if it is that easy to move an app to USB doing it your way is much simpler BUT,…your step 5 does not make sense to me. Pics attached. How do I get the “Move to USB Storage” AND what version of firestick are your steps for. As I say this is the 3rd generation firestick I am working on right now.
    Using your step 5. I selected ES File Explorer to move to USB. Where do I find “Move USB …”. Hope the pics display for you.

IMG-1843

You need to click on ES File explorer. Then in the next screen that opens with the various options you should have the “move to Usb,”

The first picture is the next screen ?? There is no option

Hey westy…

Just jumping in…

In the stik app management…

The apps on flashdrive will have the “move to usb” setting after you click on them… (permission, move,launch)

The apps in internal will not have a “move” setting

So you have to do what you you said. (dwnld from TP RAI strght to flashdrv)

Well now that explains it. Just checked and yes …the apps on the “flashdrive” do have that option. I was thinking I was daft. Thanks. From the way it was explained to me Miki was saying I could move the app from firestick to flashdrive. I thought that sounded too easy. Thankyou
At least I know how to move them back if I want to.

2 Likes

Lol. You are right. I missed that.So then you cannot move ES File explorer to external USB. Do you see the apps with the usb icon beside them? Those either are on a usb external drive already or can be moved to one. So, for example, click on Film+ and then there should be either “move to external” or " move to internal".

I’m pretty sure i used to be able to move things either way but somehow lost that ability… (probly an update)

That’s odd but the way Amazon uses a 2" firehose to put out a match it doesn’t surprise me.

1 Like