I can’t access shopping sites

I have searched extensively for someone else on here that shares my problem. So far it looks like I am the only one. I have a new router that runs IPVanish for my entire network. It has been working really well. Things are zippy fast and Ipvanish runs perfectly. Then yesterday I was unable to log in to Pottery Barn. It sends a message that something is wrong and I should try signing in again. Of course that sent up a flair of panic, so I tried other retail sites. None of them allow me to sign in. If I switch my phone to Cell Data and not use my WIFI, it works… so it has to be related to either my router itself or IPVanish. I have already accused my husband of dinking with it but he says he can’t log into our bank account on his computer either but he is able to on his phone. Any thoughts as to where to start trouble shooting?

Try changing the vpn server you are connected with. Also look in your router settings and see if you have anykind of ad blocking going on. Many dns servers will filter certain sites. Your issue seems to me to reside in your router settings…the secret is finding the culprit.

1 Like

I bet you have an ad blocker. I got one then found I couldn’t log into some sites. Turned off the ad blocker, problem solved.

Very good point. These websites try to say they need ads to make money… so sometimes when a ad blocker is detected by the website it auto blocks your ip from logging on.


Id like to add that make sure your vpn is in the same country you are buying in, that jas conflicts with some sites.

1 Like

Hmmm… that’s an interesting thought. My Ipvanish server is in Chicago. I would assume Target, Pottery Barn and Krogers were in the US but who knows. So would the Ad-Blocker be on the server because it affects all our PCs, a Chromebook and two IPads. Here is what I am thinking… push the factory reset button on the server and start over. I am afraid that I am going to make a change on it and make IPVanish mad and not have it start. Thanks to all of you for your help and thoughts. You guys are the best!

The additional info makes a difference regarding multiple devices and the same issue. So no, an ad blocker is less likely, unless you’re using exactly the same app on each device, with a possible imbedded ad blocker. GL.

My Asus ZenWifi AX6600 mesh router not only has AdGuard but also parental controls available in it’s own app/software. I could be wrong, but I feel like maybe a setting on your router could do all that you described.

In my experience, the number of websites and retailer/e-tailers that block vpns are increasing. Last night I was not able to make a purchase with the vpn on. Its not new, but is happening more frequently.

I also agree with you guys that VPN could be the culprit here. I feel like it has to be VPN or router app/setting that is blocking this, one of the two or maybe even a combination of both.