Firestick will not load

it will not go any further than the loading screen. I’ve done all I know to do to try to reset it, factory reset it, nothing works. i need some help if anyone has any idea what i can do to reset the firestick.
I’m not sure but i think it may have something to do with my son playing with it and maybe deleting the launcher, I was using “Wolf”!
I can usually figure out how to fix small issues, but this has me at my wits end!

Ooo. If he uninstalled Wolf without first going back to the Amazon stock launcher then your only choice is a factory reset.

I am having the same issue on one of my firesticks. It has been out of commission for the last couple of days.

I turn it on and the fire tv rebooting screen just runs endlessly… never boots up to the menu. I also had recently added Flauncher.

1 Like

it will show the firstick logo like it is starting then it goes to the loading screen and just gets stuck there. it wont let me even go into the settings

how do i do a factory reset when it wont let me into the settings

1 Like

Just to add to the same question…I tried rebooting and holding down the right side of the input circle and play button for 30+ seconds (so called factory reset). Didn’t work either.

Hold the right direction on the external direction ring and the return arrow.
https://www.amazon.com/gp/help/customer/display.html?nodeId=GBVZEZKT6A6LH4UP

how long should it take to reset?

I am not sure of the exact length of time. I’ve been fortunate and never had to factory reset my sticks.

I held it down for over 30 seconds… no good. I think I managed to brick it somehow.

can it be unbricked???

One thing to try is to completely unplug the stick from everything and wait for 10 minutes or so to eliminate the possibility it’s overheated or stuck on an I/O operation. I have heard of one person unplugging it from the HDMI port on his TV but leaving the stick powered on and then setting it in a place with an unobstructed line of site to the modem and leaving it running all night. He then turned his TV on in the morning, plugged the stick in and be darned if it didn’t work.

I will try option 2 and check it out in the morning. :smiley:

1 Like

I tried all options on the FS and it still won’t boot up…just the initial firetv startup graphic loop. No menu.

Oh well, I was planning on upgrading to a more powerful box anyway and had pretty much decided to get the Nvidia Pro Shield.

Now all the complaints about the current upgrade has me holding off for now.

This topic was automatically closed after 7 days. New replies are no longer allowed.