Firestick disables USB port

Newest Firestick model - Fire TV works fine however USB port is automatically disabled. Tried using HDMI 2 or 3. Cannot use 1 as USB port on TV directly above. Pioneer Fire TV 2021 model. Settings/Input/Media menu no longer appears when Firestick plugged in…

Amazon Firestick support says contact TV seller… Best Buy…

Any ideas appreciated

Regards

1 Like

I dont have a firestick hooked up right now but check in developer options usb configs.

1 Like

Doesn’t exist anymore only ADB debugging and install unknown applications.

Yes. Did you use the debloat tool?

package:com.android.documentsui (USB Drive Access

I actually was doing some research on the debloat tool for FireTV OS 7 and noticed this setting. So if you did use the debloat tool then run it again but uncheck the above option and see if that helps.

1 Like

Thanks Miki, I really didnt want to hook up my firestick :sunglasses:

1 Like

Where is this in settings?

Oh it isn’t specifically in Firestick settings. It’s if you used the Firestick Debloat tool for FireTV OS 7.

I’ve been doing a lot of reading up on this issue and wow, I had no idea. The universal problem with FireTV not allowing the usb port is the adb debugging option. Apparently when enabled it doesn’t allow the usb port, so to test this, toggle ADB Debugging off and give it a go.

1 Like

Thanks for the info. Looks like there are a lot of people with a similar problem. Like I mentioned the USB port works fine until I install the FireStick. I tried all the possible solutions, including ADB debugging, in the Streamers World nothing worked.

Looks like the Firestick is going to be returned as the USB port is more important to me…

JW

Did you try turning off the adb debugging? That seems to be the main issue. When you do I would do a reset of the stick. Unplug it from the tv and power, wait for a minute or so, then plug it back in and make sure the stick is using a wall plug for power not the USB on the TV.

Just to add to this conversation, I replaced my firestick with a firecube about 1 month ago. I decided to install tduk debloat tool for os 7 to block updates 2 days ago and it worked properly. Now I just received another firecube to replace my wife’s firestick yesterday and when I install the same debloat apk it will no longer block amazon system updates. I’m just wondering if anybody knows something about this no longer working or is it me? Please help me Miki.

Try the stand alone update blocker.

https://www.techdoctoruk.com/sdm_downloads/tduk-fireos-update-blocker/

2 Likes

Restart Firestick or reset to factory defaults? I did turn off adb debugging and restart firestick and it is using wall power

1 Like

No don’t factory reset. Doing it the way I mentioned clears any potential i/o issues.

Got it to work bit convoluted maybe it is just my unfamiliarity with streaming devices. 2nd call to Amazon Firestick Support helped. Boot into Fire TV then use voice command on FireStick remote to “change source input” then quickly grab the Pioneer remote and scroll down to media player which switches you into the USB and regular TV. You got maybe 3-4 seconds before the menu goes away… You have to use voice as there is no way to switch via remote…

I tried that link and installed the apk, it seems everything worked when I’m in the app but when I go to my fire tv-about-check for updates, it doesn’t appear to have done anything. Maybe I should stop worrying about what Amazon will do. Inevitably they’ll probably do whatever they want in the long run. Regardless thank-you very much for the help Miki, and now back to streaming while I can.:smile::+1:

1 Like

Nice job. Wow that’s very helpful. Tx.

This topic was automatically closed after 7 days. New replies are no longer allowed.