Firestick 4K cannot find purchased app in my apps

Purchased (free) a vpn app from and installed properly on first Firestick. Trying to download on second Firestick I get message “you already own this app”. The problem is I cannot find this “owned” app in the list of apps. I must be missing something very obvious. Anyone? Thanks.

1 Like

Make sure to sync your stick with your account. Go into account & profile settings and then Sync Amazon Content and see if that works.

1 Like

Thanks, Miki. I will have a chance to try this later, but I’m sure you’re right. … and thanks for being patient with me, “Captain Obvious”! Will let you know.

Sorry this has taken a while. Am I allowed to mention the actual vpn name? I tried syncing my Amazon content the way you said, but it still doesn’t come into my apps on the Firestick. The vpn support said to download it through since it can’t be found in the app store. Did that but it cannot be found to install. Still says I already own it. Other ideas? Thanks.

This topic was automatically closed after 7 days. New replies are no longer allowed.