Fire tv logo just spins and will not load

I’ve tried restarting, unplugging, letting it run for hours. It doesn’t even let me get to the settings. Any ideas?

Has your Firestick updated recently? Last time I experienced something similar to your situation, it was due to an update that stalled and didnt install fully. I had to trash everything and do a full reset.

I believe I blocked the updates.

Hmmm. I would try the full “remove power” options. Unplug the stick completely from power and the HDMI port. Let it cool down for say 15 minutes. Power cycle your modem/router. Plug the stick back in and make sure you use the power brick that came with your device and plug directly into your house power, not the usb power on your TV. Then try firing it back up. If this doesn’t help then maybe time to try a factory reset.

I’ve tried it on 3 different Tv’s in 3 different households. It was unplugged for days in between.

Ohh ok. Well I’m afraid all you can try is a factory reset using your remote.

How is that done? the remote wont do anything. Even changed the batteries

There is a keycombo you need to hold down for up to 30 seconds. If I remember correctly it’s the right direction and return arrow that you press at the same time.

@Mike9r I believe that is correct…& for a reboot from remote I think it’s the play/pause & select buttons at the same time…but not positive.

1 Like

I see! has there been any App/APK updates? I’d assume if there has been, one is maybe corrupt or failed. Other than that, I’m unsure what would solve this other than a factory reset.



It sounds like your device is bricked. Did you say you blocked updates?

1 Like

Yes, I blocked the updates as recommended by TROY POINT. I don’t know what bricked means but others have mentioned that. Is this just a throw it away and start over situation? The stick is only 6 months old.

Did you try the factory reset? That seems to be the only potential solution at this point. “Bricked” means it’s unusable and nothing can be done with it, other than maybe using it as a doorstop.

Can’t get it to factory reset either, tried 3 methods with the remote.

Damn @Mike9r I’m sorry to hear that, holding the “right” side of the directional ring and the return arrow while the stick has that rotating circle should have started the “Factory” reset function. At this point I don’t have any more ideas for you. Sorry.

I had the same problem. Tried a new power supply but just would not boot up. Ended up trashing it and buying a new one.

1 Like

Sorry nothing is working for ya @Mike9r …Got a Walmart close by? $20 for an ONN…

Well thanks everyone for trying to help, looks like trash is the answer. Fortunately, I bought 2 of these from amazon when they were on sale so I will start the process of reloading the 2nd one.

1 Like

Well you have a spare remote now. I paired my old remote to my new firestick. Now the wife has her own remote.

If you do go the restart route please make sure that if you attempt the 3rd party launchers like Wolf, that if you have to return to the Stock Amazon launcher do so by using the Launcher manager. Do not simply try deleting “Wolf” as this will definately brick your stick. But if this is a “new” 4K Max then when you start it up and update it you won’t be able to use 3rd party launchers any more. My Max is now at
If you need help finding settings to turn of stuff like “autoplay” let me know. Good luck.

1 Like