Fire stick 4k issues

My fire stick 4k is not working as it should. I’m unable to restore to factory settings, can’t watch Prime video content, can’t update, and alexa prompts do not work. Any thoughts?

What happens when you go to My Fire TV>Reset to Factory Defaults and click it? Any warnings or pop ups?

factory reset your Fire TV device using your remote:

  1. If needed, safely eject expandable storage.
  2. Press and hold Back and right side of the navigation circle together for 10 seconds.
  3. On the TV screen, choose to continue or cancel the factory reset. If you don’t choose, the device resets automatically after several more seconds

When I try to reset it in settings it prompts me to reset it, I click on reset and nothing happens. I then tried to reset it by pushing the back button and right directional button and the same prompt comes up but nothing happens after I push to reset.

Try leaving it unplugged for a few minutes then plug it back in and try the reset by holding the buttons during boot.


I’ll echo @Jayhawks659 with one more step. Remove all power from the stick and unplug it from the HDMI port, wait for a couple of minutes then plug it back in and follow @Jayhawks659 instructions. One more thing, if you don’t push to reset after holding the remote buttons and instead wait for the stick to auto reset by itself does it then go into factory reset?

Holding the back and right direction buttons during reboot?

I tried letting the 15 second countdown lead to a reboot. Nothing happened. I’m about to unplug and sit for awhile then reboot while holding the buttons. Thanks!

1 Like

It still won’t reboot. I think I’ll throw in the towel on this one. This is my 7th fire stick and the only one that’s given me trouble.

Ya Time to contact Amazon and get a replacement

1 Like

This topic was automatically closed after 7 days. New replies are no longer allowed.