Fire Cube: all files in KODI have the same date in 1905 (via my NAS)

I have the weird phenomenon that my KODI-Installation on my fire cube (and before that on my fire tv stick) all have the same date: 1905. Makes sorting of course impossible.
The videos reside on my Synology NAS (software is up-to-date).
And, get this: using KODI on my desktop windows computer attached to the same NAS all the files show the correct date just as in the file system (e.g. windows explorer).
I have tried reinstalling, deleted chaches … to no avail …
I have found some entries in the internet where people seemed to have the same problem, but no real solution …

Sounds like a handshake error between synology and the fire device. Not sure who would be to blame tho. Have you tried using an android box? I would be curious if the same result on android vs fire. Fire devices attempt to be closed by default and not very friendly with outside input… just me thinking. But I would try an android box and test it.

This topic was automatically closed after 7 days. New replies are no longer allowed.