Downloading apps on Amazon Fire Cube

How come I can’t download any apps and everytime I try I get this message in the picture I posted

1 Like

Looks like you’ll have to download them on your PC and sideload them.

1 Like

Lol I have no clue how to do that please help me, I am losing my mind.

1 Like

Hey Tdub, welcome to the insider…

Check yor storage…
Make sure u hv Dev options turned on…

What store are u trying?

The 1 in 96960000 just worked 4 me… so unlinked is workin


1 Like

Download the app to your computer from the link on and then sideload it with ADB-link. Or download the app directly on your FireTV device with Downloader from the link.


As @sktn77a mentioned you can download it from TP by using downloder here is the link how to do it.

1 Like

Can’t honestly say, but it looks like you have McAfee AV and it rejected the sites certificate. I’m not sure how you bypass this in the McAfee settings. There should have been an option to ignore and carry on to the site if you chose to. You may be able to get the APKs from another site with a valid certificate that McAfee will accept.

Also apps2fire or easy fire tools will allow you yo transfer via wifi any apps you have installed on your computer, phone or tablet, as long as the app is compatible.

What’s McAfee doing there, according to McAfee everything should be verified first. So everything will be denied access :joy::joy::joy::joy::joy:

Last think I heard about McAfee creator that he passed away in prison, because he couldn’t get out of jail somewhere in Spain.
:latin_cross: :dove:


I did download it from the Troypoint page I dunno what’s wrong I have developer options on I’ve had this for a few years and this just started happening a few months ago I have tons of storage space so I know it’s not that… Aggh FML.

:joy::rofl::joy::rofl::joy: I have no clue what Macfree is doing on this. I have a 2nd generation fire cube I’m bugging out, I can’t update or download anything… Smfh HELP ME PLEASE :pray:


Pretty sure cubes dont come with macfee. Try downloading it from a different source like apk pure and try the unmodded version.

I’m using unlinked 12341234 and I have plenty of storage space developer options are on everything that is supposed to be on is on so I’m losing my mind… Lol smh

Hey @T_dubbs As Miki alluded to…where is the McAfee coming from? Can you disable it?

Hey T…

The 1234 store in Unlinked i believe has barely worked for a little while now, (last i heard)

So maybe try that othr store in unlinked that i mentioned a cpl dayz ago, (cuz that 1 dwnlded for me) or use Apkpure as Drac suggested

Idk, maybe an update got ya

hth… GL


Maybe you clicked accidentally on something while browsing the internet. Also it could be when installing free software.

“When installing a software " many free software uses this method” you will get the the option to install McAfee, but the option is already checked without knowing it, when clicking on next to complete the installation, you installed the software includes the McAfee as well".

Those are just a suggestion and those are two of many possibilities.

Also you can navigate from your device Settings> apps if you find anything with McAfee just removed or deactivate it.

You can check their website before doing anything else the support site provides many solutions on how to uninstall, and check only on how to uninstall from link below.

did you manage to get your issue resolved? From the reaearch I did, it looks like you’re using a mcafee secure web browser that is sandboxed. Try another browser or go to the mcafee web site and they have help for this issue. Thanks to @Matrix He has a good link with lots of info that could help you. Open it and read through it.


Make sure the FS is register to your Amazon account.

This topic was automatically closed after 7 days. New replies are no longer allowed.