Cinema HD issues

Since the most recent upgrade on Cinema, I cannot get anything to play. Any ideas?

Mine plays, but new some of the newer movies play a completely different title.

1 Like

And the sort favorites doesn’t work worth a darn. It sorts them but when you close out of Cinema it reverts back to random order. Another update that made more problems than it solved. The price of free is mild aggravation.


“The price of free is mild aggravation” well said!


Same here, Cinema strikes out again on their updates. They were doing so well for awhile, so here we go again. I’ll wait a couple of days to see what happens…plenty of other apps out there. For now I just use Cyberflix.

1 Like

what version are you running,I used Cinema all day yesterday with no problems. I was using v2.3.5

Uninstall it. Reinstall using
Do not update. At least not
until a newer update is available.
Many new updates are full of
issues and ads.

1 Like

Thanks I was having issues and I tried again and it works. .Thanks

I’ve running into this problem with CinemaHD for a while: subtitles will load and show as they should but after a day or so, subtitles window will come on, but when clicked on a choice, it will not load. The only way I can overcome this is to delete the app then reload again, and it’ll work right again for another day or so. It becomes a pain to have to re-activate RD each time.
BTW, Troy, how come CinemaHD is not in the rapid loader anymore?

1 Like

try TeaTv or BeeTv. both available in the troypoint rapid app installer. i used to use cinema a lot, but most of the links didn’t work or played different movies than what i selected.

TeaTv works a lot better for me than Cinema ever did, i don’t even have Cinema installed anymore

1 Like

Anyone else having problems with Cinema playing different movies than what is listed. For instance Ghostbusters Afterlife has streams but then it plays Adams family or the original Ghostbusters from 1984.
I seem to be find the issue a lot lately. Thanks for your input.

Yes. That’s part of the reason I no longer use it. Often though if you read the source listing it will say what the link will play. No Ghostbuster in the title, it’s likely something else.

1 Like

All cinemahd issues here.

Try switching to something els.

Kodi seren crew