Can't get links in Kodi builds on Nvidia Shield

This is really wierd, and I’m hoping that there is a simple solution that I’m overlooking or a simple toggle switch to fix it.

I’m a long time Fire Stick/TV user and recently bought a Nvidia Shield because of the advanced options it offers - so I’m pretty familiar with the process of getting to the media I want. It was working great until some of the recent upgrades in either the Kodi platform and/or the Kodi builds (i.e., Xanax, No Limits, etc.)

When I use a movie add-on, and select a movie, it goes through the normal searching for viable links (I also use IPVanish and Real Debris consistently) and when it gives me the option for the link I want, I then select that link and it cycles through as normal to start the movie. But now - EVERY time I select a move (and I’ve tried at least 50 times), it goes through the whole process as normal, but then right at the very end it says “unable to find link”, or “one or more items failed to play. Check the log…”

I have tried twice to completely wipe the Shield clean and start over, but it still does this.

Anyone know of either a fix, or recommendation on what to try or look for? Any help would be appreciated!

Have you checked the log for the error messages? Using Log Viewer for Kodi?

1 Like

No I haven’t - what should I look for? Is it in settings?

To install Log Viewer for kodi:
Open kodi

  1. Go to system-settings
  2. Click addons
  3. Click install from repository
  4. Click kodi add-on repository
  5. Click program add-ons
  6. Click log viewer for kodi
  7. Click install

I recommend configuring the settings as follows:

  1. After you installed in step 7, click log viewer for kodi again
  2. Click configure
  3. Select invert log (most recent first)
  4. Click show log when an error occurs
  5. Click ok

Repeat the steps that previously led to the playback errors and message to check the log file. Hopefully this time you’ll get some useful information about what’s going wrong. It’s a starting point…

Good luck.

1 Like

Thank you for the detailed steps - I did everything as stated and even wiped my Shield, re-installed Kodi and the Titanium build (previously tried No Limits & Xanax) which I have used in the past. I went through the same process, selected a movie and waited for all the links to show up, selected a 1080p video, then waited for that link to complete, but when done, I still get the “no stream available” message. Then I went searching for the event log but couldn’t find it. Can you help once again??


If the log file didn’t pop up when the error occurred, you can bring it up manually.
Open kodi

  1. Go to system-settings
  2. Click addons
  3. Click myaddons
  4. Click program add-ons
  5. Click log viewer for kodi
  6. Click run

Choose the option to show most recent messages at top of log. Look at the time stamp to verify the error messages coincide with the time you attempted to pull up links. Sometimes these messages are pretty cryptic but hopefully there’ll be something there that at least gives you an idea as to why kodi can’t play the links.

1 Like

What version of Kodi are you using ? 18.2 and i believe 18.2 have problems with builds. Let me know the exact version you are using and I can advise.

I specifically reset from scratch using Kodi 18.1, and it still does the same thing.

The strangest thing is that I’ve reset it 3 times now, starting over, and it does the same thing. I can use the Cinema and Bee APK’s without a problem, but I’d like to get Kodi and the builds to work as well. Ultimately I’m trying to be a full cord-cutter, but need everything to be working before I ditch the bitch (Comcast). :slight_smile: :stuck_out_tongue_closed_eyes:

1 Like

I’m assuming you’ve tried various addon’s within the build to see if there’s any difference.

Yep - the most common message is “no stream available” after it gives me 100’s of links.

Yesterday I tried the Xontech build and i’m Going to see how this one works. My 5th build. I’m starting to think it might be a setting or something.

Sorry to hear you’re still having problems. I’ve attached a link from kodi tips that discusses the no stream available problem. You may have already know this stuff but maybe there’s something in here that’ll provide a clue…


Really appreciate the link. Didn’t realize that this is a common issue.

I’ve already done most all of the “fixes”. I’m hard wired, have reset Kodi, etc. I think the only thing that I can try is to NOT add a build and just select one or two trustworthy add-ons. I’ll have to remember how to do that! :crazy_face:

I really do appreciate the time and effort to help me out. I’ll keep you posted.

This could be and issue with Real Debrid and your VPN.
You have to remember many users are likely sharing your VPN address while real debrid only allows one connection at a time per account.
I would try to turn IP Vanish off and see what happens.
If that doesn’t work I might try to reauthorize real debrid in you kodi/build settings and then try again with IPVanish off.