Can’t check network status firestick 4k

Can’t check network status using pause/play button firestick 4k. It use to work but now it doesn’t. When I press the button nothing happens. Software is up to date and restarting firestick didn’t help. Pressed menu button to forget network and signed back in. Firestick is connected to network and internet and I can go to home screen, use all apps, and stream shows and movies. Everything is working fine except for this. Anyone else having the same issue?


Unplug your stick, leave it for a bit, next make sure it’s getting power from the wall and not the TV, make sure to update it to the most recent update and try again.

Thanks for your reply Dracoo. I did what you said but it didn’t work. I tried the remote with a different firestick and it worked. So the issue is with this firestick. Maybe a software update glitch. I thought about a factory reset but I really don’t want to do that. This isn’t that big of deal but I expect it to work. Thanks again.

My pause/play button has only ever done just that, pause/play. Not on any of my 4k sticks has clicking the pause/play brought up my network. I’ve only ever accessed that through the control panel under the “network” icon. I tried it last night on my Max during the live feed I was watching and it did exactly as it’s suppose to, paused then second click, played.

1 Like

Thanks for your reply Miki. I’m talking about going to settings/network/ and then after highlighting the network you want to check push the pause/play button. This should show the status of that network. My pause/play button works fine for what you are referring to. I’m trying to check the status of my network connection. Thanks again.

Ahh. See I misunderstood I missed the part where you said you went to the network interface first. Yes once there clicking the pause/play has always brought up the status on my 4k sticks. Ok now I’m on the trail of something new to look into. I’ll see if anyone has ever had this issue before.

Thanks Miki. I apologize. I wasn’t very clear about going to the network interface first in my original post. Thanks for your help.

Hey all good. I should have figured that out myself. Oddly enough I did find one user who had this issue and fixed it by using ES File Explorer and selecting the Amazon apps one at a time and “uninstalling”, now that doesn’t actually uninstall them it just returns them to “factory” settings. This apparently restored the Network sub menu after he removed power from the stick unplugged it from the TV and waited for a minute and then put it all back together and restarted the stick. Worth a try.


Thanks Miki you fixed it. After you mentioned that person uninstalling the Amazon apps and reinstalling them, that got me to thinking about possibly an Amazon service being disabled. So I went to a debloating tool I use and enabled everything. That fixed it. I never would have thought of that without your help. Thanks again.