Brave Browser - won’t open

I installed Brave Browser on Firestick 4K. It begins to open and then closes to the Firestick Home Screen. Tried deleting and doing a cold reinstall. Same problem. Any suggestions??? :weary:

Might be running out of storage. You need at least 1.3 gb free space but more the better.


Haven’t used my cube in a while but I remember you have to make sure the version you pick has to have the right architecture so sometimes I had to use an older version. Apkpure has many variants. This one should work


Thanks! That worked. Still a small problem. I’m using Mouse Toggle but can’t scroll down pages. Any ideas.

I’ve got the free space. See below,

I thought you could scroll with mouse toggle on by pressing the 2 purple buttons. Not sure cause I used a wechip airmouse.

Maybe try directional keypad up and down without mouse toggle.

Thanks for the second time. It works but Brave is slooow and clunky. Guess I’ll just use Silk!

1 Like

Just use the Mouse Toggle to navigate on the page. If you wish to scroll you need to disenable the Mouse Toggle and use the on screen mouse.

This topic was automatically closed after 7 days. New replies are no longer allowed.