Am I doing something wrong?

I’m beginning to think I’m doing something wrong. I can’t get any stream to work without buffering or just stopping.
I have a 100MB fiber-optic connection and I’m using IPVanish.
I downloaded the latest version of Sapphire and it seems to now be called Universal.
I’ve tried using this Universal and I’ve tried using Red Box but neither of them will stream without serious buffering. I mean unwatchable buffering. 1 or 2 seconds of stream and then 10-15 seconds of buffer.
I can stream on my iPad and mirror that to the tv and that usually works ok, but anything through the firestick just won’t run.
Any suggestions?

Did you change to the new IPVanish protocol?
wireguard
It is faster. I also recommend checking all your connections to ensure they’re tight. Use the Troypoint guide on reducing buffering. Make sure background apps are off. “Background apps and process list” is available in the Amazon app store.
Keep the cache cleared out in all apps. I do this every night before going to bed. I also never leave my stick powered up over night. I have my stick plugged into a no surge bar that has an off switch. Firestick buffers like mad once it gets hot. I also use the HDMI extender supplied with the stick and have made a little hanger to keep it away from the back of the TV and allow air circulation around the entire stick. Good luck

1 Like

Ohhh…I don’t know about that. I will try it.

Thanks

Look up Troy’s tutorial on adding storage to the firestick via USB cable.

Thanks, I will try that, too.

I have switched to fireguard and it does seem to be working but there isn’t a big game on at the moment so I can’t be sure.

How long have you been using that firestick ?? I dont wanna say this, but, and I mentioned it in another post, you might need to do a reformat of your stick. I would recommend doing that as a last resort but the caveat that seems to be in play is that you can rock out on your iPad with no issue. I wouldnt think that its a connection issue as it works on one but not on the other. If it was a grumpy signal, you would prolly have it on the iPad also.

My experience is that after a while, its not a bad idea to go back to factory settings. I was having HUUUGE ISSUES with my buffering but when I reformatted, all was well. Just a thought.

I’ve had my 4k Firestick for 3 years and never once had to do a factory reset. I personally don’t believe it’s ever truly necessary unless you have malware/adware you can’t root out. Overheating on the firestick is a huge issue and if your connection and other devices work flawlessly then I put my money on the overheating issue. For my customers the buffering is always a result of overloading the stick and not cleaning out caches. I always configure sticks so there is at least 2GB out of the 5.34 GB available. Everyone that calls me that has buffering has loaded countless apps, has less than 1GB left, never shuts down background apps, never clears the cache, and never updates the OS. In the 2 yrs I’ve been optimizing and configuring sticks I’ve never done a factory reset. Maybe I’m just lucky.

Just wondering if you are using a different media player than what the service provides. On my IPTV, I can’t remember if they recommended using VLC media palyer or if I read it somewhere else. Needless to say the VLC made a difference. Another one to use is MX Pro player. Just a thought, hopefully you or someone else can help you fix the issue.

I’m using MX Pro as recommended by Troy. Can’t honestly say if it’s help reduce buffering or not as I so rarely have buffering issues. Something else I should have mentioned, and forgot, is if you have a dual band modem and your firestick is in the same room and hopefully only about 20 ft away, use the 5Ghz band instead of the 2.4. It’s faster. Now I’ve heard that using an ethernet adapter is faster and that isn’t necessarily so, especially if it only has say a 100Mb switch in it. I am fortunate and don’t have any interference so my WiFi is stable and fast.

Idk about all that. When I downloaded the new app for Sapphire it was just a custom version of Smarters and they labeled it “my tv”. But I still opened a support ticket to get the new m3u url so I could use it in Tivimate. It definitely takes a few seconds to load the channels now, but I haven’t noticed a ton of buffering after it starts. But I have it as my backup service now. I haven’t been using Sapphire consistently.

My streaming service provides m3u links and I typed them in to IPTV PVR Simple Client on Kodi 19.1 Matrix. The past week or two I’ve had horrible buffering to absolutely unusable, to the point that I thought they had maybe gone down. I am currently trying the Apollo trial and still have buffering/nonworking services.
It seems you’re experiencing a similar issue to me. I have discovered that switching between Protocols in IP Vanish helps. I’m using a Shield (2017/Ethernet) for the Apollo trial so I don’t think it’s your Firestick. I also have a Firestick 4k and have this problem.
I can repeat this problem on Firestick 4k. Also on my Shield using the same streaming service on Perfect Player, IPTV PVR Simple Client/Kodi 19.1 Matrix, and the services own app and I’m finding that the problem resolves by switching IPVanish Protocols. Also, make sure you keep your devices cache cleared, too.

Try this set up. You don’t have to get as large a HDD as the one shown, but I would get at 128GB . You can get a flash drive instead of the one pictured, too. All these adapters can be found on Amazon. Personally, I am a big fan of Nvidia’s, but to each his own.

I can’t use this sett up as I would have to run an ethernet cable across the living room which I don’t want to do. So I went for the factory reset. That seems to be working ok so far but it’s not peak viewing time right now so I’ll check later.

Ok, then maybe try this: How To Setup Powerline Adapter for Ethernet Connection (Fast Streaming) (troypoint.com)

2 Likes

Before you go spending more money try using a different IPTV provider. This is exactly why a bunch of us subscribe to two services, in case one stops working. Just buy a one month subscription.

I was watching Sapphire this morning with Tivimate and it took a good 30 seconds for the first stream to play. I even changed my buffer size to none. Some channels were faster than others after that though. But once they started playing I didn’t have any buffering. I was using my 4K firestick. The last time I used Sapphire on my shield it was the same.

On one of these IPTV Telegram chat sites a mod told me that if a channel that sits idle and isn’t used often takes longer to load the first time. That is the first time I had ever heard of that and don’t know if this mod was just blowing smoke? Although, I will say this, after the initial bootup of said channel. It did bootup faster after that. So hmmm…?

I am still using my 6 year old 4K box and never had to do a factory reset. Likewise have customers using the same model and various models of FireStick without issue. I don’t particularly rate the Red Box app. In my part of the world (Spain) 15 Mbps is a good speed and we have little issue with buffering so it looks likely its down to the way that stick has been set up.

Often as not ppl blame the firestick. Here in Mexico I blame the IP. Poor connection, lag, and line noise, not to mention the heat.

This topic was automatically closed after 30 days. New replies are no longer allowed.