4k Fire Stick OS update error

My 4k Fire Stick won’t update the latest OS version. Keeps trying, then an update error shows. I have tried everything. My second 4k stick updates fine. Would anyone know any fixed please?.

When I had issues, using the same internet connection, I would swap the one that wouldn’t update to the TV that would update it. One of my Tv’s is wireless which I thought might‘ve been the issue. Updates fine now…

Thanks for that Jags. It seems I haven’t tried everything after all. I’ll try that and re post. Cheers.

1 Like

Tried on different TVs, Lan and wifi, no success. Still won’t update…

I had this issue as well. You might have to do a complete factory reset and then it will update. That little thing does A LOT and takes on A LOT of bloatware and “stuff”. Sometimes it just gets to the point where it wont do what its supposed to do.

Thanks Ahdedon. I was hoping not to factory set. I don’t think I can cope with another full setup at this time…

OK. You’re text mentioned Bloatware. That made me remember that I debloated my stick with using a debloat app. I re enabled all the Bloatware and the new updates downloaded immediately. Thank you all kindly for the help. Cheers.

NP, Anything to help. I know its a drag but its inevitable for just about any device. Computer, phone, etc etc. Just think though, it will be running sooo smoooove clean. :grin:

This topic was automatically closed after 30 days. New replies are no longer allowed.