19.1 smb setting not working

I’ve upgraded from 18.9 to 19.1 and I can not longer get my SMB access to my hard drives. I’ve reviewed all the information about going to the settings>services>SMB and changed the smb min/max SMVv1, tried added my router IP and turned on/off the legacy and continue to get the network error. I’ve removed the source and added again. Unplugged stick & TV both. Still nothing. I’ve been using the stick since it first came out on multiple TVs and set up Kodi for a lot of my friends/family. Pretty familiar with settings. I’m getting very annoyed and wonder why others can get the smb to work and I can’t. I love the user interface on kodi for this. Any suggestions I’m not a fan of PL*X.

@keepnpeace

welcome to our amazing community!!

Read this, I got this from a reddit user experiencing the same thing. “Pruthisith” credit to them.

Thanks everyone for help posting the fix for this version.I’m not sure why this is happening, having SMB should be standards and I don’t know why it is getting more complicated each time.

This is the step I took and got it to working.

Go to setting > serviceEnable Expert modeSet min requirement to SMBv1 (you need to restart and come back)Set max requirement to SMBv1 (you need to restart and come back)

At this stage you will be able to connect SMB now but got stuck in user/pass. This doesn’t work with non-user/pass folder.If you want to access the folder then do the step below:

After the above setting, Now Legacy mode will be available turn it ON (you need to restart and come back)DONE!

Now if you have the previous folder configuration, then this should fix it for you immediately.But if you are new user, then you need to re add the directory again (smb://YOUR server IP) and then go in and add each shared folder one by one.

Also on the step above I did setup the workgroup to be the same one as my server and also setup WINS server to the same IP address as my router/gateway

1 Like

Thanks @Dracco. I have tried this suggestion every which way and still getting the network connection error. Scratching my head since so many other people are saying this is a fix for them. A few other thoughts rolling around like reboot my network/router and doing a factory reset. Luckily, in the meantime, I have extra sticks around with 18.9 version with smb working fine.

@keepnpeace

Last link to provide. I’m honesty not sure seems to be a current issue across the board. Hopefully someone can come in and be more helpful than I.

Hope this gets resolved.

I ended up with a factory reset and installing 18.9 back on all my sticks so I don’t have to deal with this. It used to be so easy to add this as a source, then Kodi complicated it with 17. Now they’ve decided to make it extremely difficult to stream your own network. Oh well, I really only use the stick for easy access to hard drives. A few back up addons for movies/shows we don’t have in our library. Just have to click OK when I get the kodi upgrade message :slight_smile: